Reviewing and Entering Plats into the GIS

Follow

CP = Concept plan
PP = Preliminary plat
FP = Final plat

P&Z = Planning and Zoning Board, CC = City Council

Submittal Requirements: Official City of Round Rock Platting Packet:

Digital Format - 2-CDs, in a digital format such as AutoCAD “.dwg” files, MicroStation“.dgn” files or ESRI “.shp” files. Each CD will include the following: A digital copy of the Plan georeferenced to the State Plane Grid Coordinate System –Texas Central Zone (4203) or contain a minimum of two (2) survey points referenced to the City of Round Rock Control Network. The file shall be in US feet and shall include rotation information and scale factor required to reduce surface coordinates to grid coordinates in US feet; and Utility and drainage schematics as depicted on the paper schematics.

Initial Plat Review – CP, PP, FP for Georeferencing

  1. Receive by email from Planning a PDF with the list of subject projects to be reviewed for location. Open PDF.1.png
  2. File Explorer – set up a new folder for each project GIS_Share/Plats.
  3. Open Trakit, select project number > go to attachments > Select the DWG in question and email the DWG to my_email@roundrocktexas, also open the PDF of the DWG in Trakit attachments for a reference tool. Open ArcMAP and AutoCAD MAP2.png
  4. AutoCAD - Next determine if the DWG is GRID or SURFACE. A yes or no question (Texas Stateplane NAD 83 US Feet Central 4203). That is all I would like to know at this time. The preferred submittal is a plat georeferenced to GRID projection. The actual transformation if in Surface will be completed in ArcMAP > Spatial Analyst. Also, verify that the Scale Factor and Rotation Angle. The rotation is only necessary when the plat has been rotated.

  5. AutoCAD - Option 2; if the plat is not in a projection; verify that there are two sets of coordinates. The coordinates should be in either Surface or Grid and a Scale Factor should be noted on the DWG. We use the Scale Factor to complete the Transformation and georeferencing of the plat. The coordinates (encircled) in the following image are located at the Northwest and Southeast corners of the plat.3.png
  6. AutoCAD (editing DWG) – from the ribbon, Format (Tab) > Layer Manager and turn off unneeded layers, the remaining layers that are visible should refer to the boundary, lots and row. If a polyline property is in question, Select the polyline and right-click for Properties information. I also change all polylines from non-continuous to continuous. Sometimes geometry is placed on the wrong layer, so be cautious when turning on/off or deleting geometry on layers.  Don’t worry you can always use undo if you may make a mistake. CAD Layers are similar to Feature Classes but behave differently. FYI: Layer ‘0’ cannot be turned off by default, so the features/geometry must be deleted. Survey pins are located on Layer ‘0’ on 50% of the submittals. The image below show’s where the Layer tab is located on the ribbon. 4.png
  7. AutoCAD – From the drop-down Tab > MapDrafting (this is the Map/GIS function part of MAP 3D) > Tools > Drawing Cleanup tool, this tool breaks intersections, removes dangles and some but not all duplicate polylines. Next, visually inspect the dwg for any disconnected, dangle nodes or invalid polylines that may make the ArcMAP Toolbox tool Features > Shape to Polygon fail.  You will be using the tool Shape to Polygon later. This image is showing where the Drawing Cleaning tool is located.5.png
  8. AutoCAD – Export edited dwg to a polyline shape file. Select MapDrafting > Import/Export > Name_shape file > Select the geometry > right click > ok to accept. We have completed the use of MAP 3D. The image show’s where the Import/Export command is located for shape file and/or other formats.6.png
  9. ArcMAP – Add Data, add the newly created Polyline shape file.
  10. ArcMAP – If the Polyline file is in Grid, that’s great. Use the tool Create Polygon from the Toolbox > select Data Management > Features > Feature to Polygon shape file. The new shape file may be added to the MXD automatically.7.png
  11. Next, select, copy and paste polygons into an editable version of SDE Parcels, Land Use, Zoning, Subdivisions, Neighborhoods and update applicable attributes.

  12. ArcMAP – (option 1) If the Polygon file is in Surface, you will need to add or create a Point Shape file for coordinate creation. I suggest that you add four fields in the Point shape file, so that you may calculate the Surface X, Surface Y, Grid X and Grid Y coordinates. Next, add four new Surface Points (NE, SE, SW, NW) with the Snap turned on to the Polyline shape file add the four points by Snapping to the Polyline geometry. Select/highlight all four surface points and using the tool Calculate Geometry, calculate for SX, SY Surface Coordinates.  Now we have four known Surface Coordinates. Keep the four Surface coordinates Selected. Next, in the Points table use the Field Calculator (not the Calc Geometry tool) to acquire our Grid Coordinates. We multiply the Surface X(coordinate) times the scale factor = Grid Coordinate. We now have four Surface coordinates that include both Surface and Grid values. Now for the Transformation, refer to the DWG or PDF for the scale factor.8.png

    Remember, we are still editing the Point shape file. Highlight one of the Surface coordinates and with the table still open, copy the GX value to the clipboard. Next, Create Feature > Absolute XY > paste (GX) > key in the GY value from the table and hit enter. Do this until four Grid coordinates are created. We should now have four Surface and four Grid coordinates. Stop Editing and Save the Point file.

  13. ArcMAP – Option 2, this is when the DWG is not georeferenced but the georeferencing coordinates are available. Open Point file > Edit > Create Features > Absolute XY > key the two coordinate values from the DWG/PDF. We should have two sets of coordinates. Are the coordinates Surface or Grid? Sometimes, the DWG will have the coordinates defined as Grid or Surface in the calls. Only two set of coordinates are required. Stop Editing and Save.
  14. ArcMAP – Option 2 (continued) Grid, > Toolbox > Feature > Select Polyline file > Edit > Snap set to Polyline file Vertex > Select entire Polyline geometry > Using the CTRL (keyboard) drag the X and Snap it to the Polyline location that corresponds with the Grid Point 1 and Snap. Next, Drag the highlighted Polyline file to Point 1 and verify that Point 2 looks correct. Stop Edits and Save.
  15. Arcmap – Option 2 (continued) Grid, Polyline shape file > Toolbox > Feature > Feature to Polygon, we now have a new Polygon shape file. Edit > SDE layers > Select features from Polygon shape file > Copy & Paste into SDE > Update appropriate SDE attribute data > Stop Editing and Save.
  16. ArcMAP – Option 2 Surface (continued), Edit Point shape file. Create Features > Absolute XY > Add two the Surface values that are on the plat and then add and calculate two more points for a total of four Surface points. Calculate four more Grid coordinates. If necessary, refer to Section K for creating the points. Select the entire Polyline shape then drag and Snap to one the Surface coordinates. The plat is now georeferenced to Surface. Stop Editing and Save9.png
  17. ArcMAP - Toolbox > Feature to Polygon, a new polygon shape has now been created. The polygon shape file is automatically added to the mxd. SDE_Feature > Edit. Select the Polygon file and then Copy & Paste the new selected features to the appropriate SDE feature class that is editable
  18. ArcMAP – Edit > Add attribute data, Sde.Parcels, Sde.Zoning, Sde.Land Use, Sde.Subdivision’s, Sde.CityLimit and Sde.Streets
  19. ArcMAP example – Edit Parcels, Select Polygon shape file features Copy & Paste into Parcels. Open the Attribute Window for adding the attributes
  20. Update the following attributes (Parcels); RCODE, Legal Description, Subdivision, City, Zip, calculate for Acreage, calculate Parcel_ID, assign Status, Previous UID (from retired parcel), and County. RCODE is assigned a temporary id of R9999, this is permanently updated after recordation and when WCAD’s map service is updated. There is no notification from WCAD when RCODES are updated. The RCODES are updated manually. The Parcel_ID is used by Utilities and is updated with a Python script manually. I also adjust adjacent features with the Survey grade geometry from the DWG Submittal.
  21. ArcMAP – Streets, Create Feature add the polyline geometry – Snap to Parcels > Select Parcels > Trace Parcels > copy parallel according to the Right-of-Way dimensions and then delete the first feature created.
  22. Add Street attributes
  23. ArcMAP - Subdivisions – add feature by copying and pasting from Parcels. Add new feature, attributes > assign symbol > assign date > assign type. Right Click for Properties > Symbology > add all, the feature has been added. Save
  24. ArcMAP - Land Use - add feature by copying and pasting from Parcels > assign Land Use Type > Calculate for acres and clip Right-of-Way. Save
  25. ArcMAP -Neighborhoods, copy geometry from Parcels and Paste. Update attributes.
  26. ArcMAP – Post & Reconcile
  27. CORR Harn Network – Points that are a reference in the Plat and may be used to locate geometry.
  28. FYI: Parcel Status_Type: Unrecorded, Recorded, Abstract, Replatting, and Retired. We do not delete Parcel features within the City Limit, since the feature(s) may be linked to Trakit. First, GIS assign’s Status_Type to Retired or the original Parcel(s) that are being subdivided. The new feature(s) are then added to the GIS as an Unrecorded feature. The Retired feature UID is then added to the Unrecorded feature as Previous_UID, copy retired UID and paste Unrecorded Previous_ID. Unrecorded features are approved thru Planning, normally and are dependent on the Owner applying at the Appraisal District for recordation. We receive notice from Planning when a plat is recorded, however at this point we do not have the RCODE. We wait until the property and RCODE are updated to either WCAD or TCAD map services. Abstracts are a collection of legal documents that chronicle transactions associated with a parcel of land. Replatting is used for when there is a portion of a feature leftover in the process of subdividing. The feature is normally developed later and the Replatting feature is deleted. Replatting is used to prevent a “hole” being depicted in the geometry. The so-called hole may confuse viewers of the Parcel data.
  29. Zoning and Annexations: Zoning and Annexations are processed before the Subdivision process begins. Planning will ask either Kim or myself to create exhibits for City Council. The source document is either a deed or a sketch (PDF) provided by a Surveyor and is included in the appropriate ordinance or annexation file. The sketch is not an on the ground survey, it is usually put together from multiple adjacent deeds and the subject Parcel(s) deed or Abstract description. A digital georeferenced DWG has been never provided or required for this process.  The documents or PDF rarely provide any coordinates for georeferencing or reference points. Also, the sketch provided has no scale, since it is a photocopy which is reduced. So, we use COGO (coordinate geometry) to input the survey into the GIS from the sketches or deed descriptions. We use surveyed bearings, distances and angles to create the Traverse and check for acreage. The survey’s point of beginning rarely has the coordinates provided, so we try our best to locate the point of beginning. Later, during the Submittal process when a more accurate digital georeferenced DWG is available, I will go back and update/edit or tweak the Annexation or Zoning feature(s) to have a more accurate and precise GIS.
  30. ETJ Action: We politely request the Engineer/Surveyor for a digital copy of the Subdivision Plat. Currently, there are no requirements for any Subdivision Submittal to be reviewed by city staff in the ETJ. The plat that we are emailed is normally georeferenced to 4203 in Surface and is also a DWG. Next, I perform a transformation from Surface to Grid. After using Drawing Cleanup and Exporting the DWG to a Shape file, I continue with the process referred to in section ‘K’. Updating of Parcels within the ETJ - we receive no updates of land transaction’s or changes from Williamson County Appraisal District. I download the WCAD parcels about every six months and visually look and compare for changes and then edit the appropriate SDE feature classes accordingly. The changes are not Survey grade, they are merely a copy and paste of the geometry from WCAD. I also use the WCAD map service as a tool to obtain information and updates.
0 out of 0 found this helpful

Comments

0 comments

Please sign in to leave a comment.